FTN down

Incident Report for Criipto

Postmortem

We have received the following details from Telia:

Last night we experienced couple of huge denial of service attacks between

2025-11-17 20:31:44 EET à 20:43:10 EET

and also

2025-11-17 23:07:44 EET à 23:15:10 EET.

Our defensing mechanism has probably been the reason for this outage. I will report this to our DDoS team. Sounds like a IP range whitelisting problem to me.

As a future guard against this problem, Telia have now explicitly allow-listed our outbound IP addresses.

Posted Nov 18, 2025 - 12:54 CET

Resolved

Connection issues to Telia have been resolved. FTN is now operational again.
Posted Nov 17, 2025 - 21:25 CET

Investigating

We have observed issues connecting to Telia who helps power our FTN logins.
Posted Nov 17, 2025 - 20:56 CET
This incident affected: E-ID services (FTN (Finland)).