Finnish Trust Network down
Incident Report for Criipto
Resolved
Latest message from the provider of FTN, Telia, reports that FTN is back again. (All times are EEST, one hour ahead of CET):
------------------------------------------------

Hello,

Disturbance, which affected Telia Tunnistus brokering and digital signing services has been fixed. As a result of the disturbance, users were unable to authenticate to websites using Mobile ID or Telia Tunnistus brokering service, or to sign documents digitally.

Incident start time: 26.9.2022 12:41
Restoration time: 26.9.2022 16:05

All timestamps are Finnish time.

Our apologies for the disturbance.

Best Regards,
Telia
Posted Sep 26, 2022 - 17:01 CEST
Update
Latest message from the provider of FTN, Telia (all times are EEST, one hour ahead of CET):
------------------------------------------------

We are still working on remedying the issue. We will send out the next update at around 18:00 or earlier if services have been restored.

Incident start time: 26.9.2022 12:41
Estimated restoration time: 26.9.2022 19:00
Posted Sep 26, 2022 - 15:14 CEST
Identified
Our supplier for Finnish Trust Network (FTN), Telia, has "detected a disturbance, which affects Telia Tunnistus brokering and digital signing services. As a result of the disturbance, all users are unable to authenticate to websites using Mobile ID or Telia Tunnistus brokering service, or to sign documents digitally."

Telia is working on remedying the issue. They indicate that they will send out the next update at around 15:00 EEST or earlier if services have been restored.

Incident start time: 26.9.2022 12:41 EEST
Estimated restoration time: 26.9.2022 16:00 EEST

Note that all times are in Finnish time, EEST, which is one hour ahead of CET.
Posted Sep 26, 2022 - 13:19 CEST
This incident affected: E-ID services (FTN (Finland)).