FTN is down
Incident Report for Criipto
Resolved
This incident has been resolved.
Posted Dec 11, 2023 - 23:40 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 11, 2023 - 22:49 CET
Identified
Approximately 5 hours ago, our FTN provider seems to have been down. We reported the problem to them immediately, but have received no response so far.
Posted Dec 11, 2023 - 20:34 CET
This incident affected: E-ID services (FTN (Finland)).