DK MitID is down
Incident Report for Criipto
Resolved
This incident has been resolved.
Posted Nov 10, 2023 - 17:28 CET
Investigating
Please check with https://www.mitid.dk/ as well.
Posted Nov 10, 2023 - 15:35 CET
This incident affected: E-ID services (MitID (Denmark)).