Finnish Trust Network down
Incident Report for Criipto
Resolved
The problem was caused by a configuration error our native FTN providers configuration system, which they have fixed.
Posted Apr 19, 2023 - 14:40 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 19, 2023 - 11:54 CEST
Investigating
Users report being unable to authenticate with FTN. We are investigating.
Posted Apr 19, 2023 - 08:49 CEST
This incident affected: E-ID services (FTN (Finland)).