DNS resolution for *.criipto.id is unstable
Incident Report for Criipto
Resolved
This incident has been resolved.
Posted Oct 26, 2022 - 13:27 CEST
Investigating
Our DNS provider (DNSimple) is reporting issues with DNS resolution in the Nordics.

If you are using your own TLD towards Criipto Verify, you will not be affected by this issue.
Posted Oct 26, 2022 - 12:57 CEST
This incident affected: DNSimple Name Servers.