Criipto Verify down

Incident Report for Criipto

Resolved

Issue has been identified and resolved.
Posted May 17, 2025 - 13:31 CEST

Identified

The issue has been identified and we are applying a fix. The issue is isolated to MitID
Posted May 17, 2025 - 13:04 CEST

Investigating

We are currently investigating the issue.
Posted May 17, 2025 - 12:50 CEST
This incident affected: Criipto Verify Authentication Core.