Increased failure rate for Signatures API

Incident Report for Criipto

Resolved

We have deployed additional mitigations and error rate appears to have returned to normal levels.
Posted Nov 01, 2024 - 17:32 CET

Update

Error rate has decreased with initial deploy mitigation.
We are now deploying our second mitigation that we hope will reduce error rates to regular levels.
Posted Nov 01, 2024 - 16:22 CET

Identified

First mitigation has been deployed and we're working on a second mitigation now.
Posted Nov 01, 2024 - 14:56 CET

Investigating

We're observing an increased error rate for Signatures API related to signing signatory links, we are investigating root causes and working on mitigations.
Posted Nov 01, 2024 - 14:28 CET
This incident affected: Criipto Signatures.