Danish MitID down
Incident Report for Criipto
Resolved
This incident has been resolved.
Posted May 14, 2024 - 09:07 CEST
Update
MitID appears to be working again, but we have not yet heard back from Nets.
Posted May 14, 2024 - 08:54 CEST
Investigating
The provider of MitID, Nets, has reported that MitID is not working
Posted May 14, 2024 - 08:30 CEST
This incident affected: E-ID services (MitID (Denmark), MitID Business (Erhverv)).